Wir nutzen Cookies, um das allgemeine Benutzerelebnis zu verbessern. Mit der Nutzung unseres Wikis stimmst du der Nutzung von Cookies zu.

Versteckte Funktionen

Scratch 2.0 hat eine Anzahl versteckter Funktionen, welche zumeist durch Klicken auf ein Object oder einen Bildschirmbereich und gleichzeitigem Halten von Umschalttaste, Strg-Taste oder der Cmd-Taste ausgelöst werden. Diese Funktionen sind versteckt, da sie ansonsten neue Scratcher verwirren könnten.

Dateimenu

Der Offline- und Online-Editor haben leicht unterschiedliche versteckte Optionen die durch Halten der Umschalttaste und gleichzeitigem Mausklick auf das Dateimenu aktiviert werden. Im Online-Editor kommt hier eine Option "Save Project Summary" (Projektzusammenfassung speichern) zum Vorschein. Umschalttaste plus Mausklick im Offline-Editor lässt hingegen die Option "Import Experimental Extension" erscheinen.

Edit Menu

The shift-click accessible Edit menu options.
The 'Edit Block Colors' menu

Im Online-Editor erscheinen weitere Optionen nach einem Mausklick auf das Edit-Menu bei gehaltener Umschalttaste. Die folgende Liste beschreibt alle Optinionen die so sichtbar sind:

Turbo-Modus

Klicken auf die Startflagge bei gleichzeitigem Halten der Umschalttaste aktiviert den Turbo-Modus, bei dem das Projekt ohne Wartezeiten zwischen den Blöcken ausgeführt wird. Das kann bei langwierigen Rechenoperationen sinnvoll sein, wenngleich ein ähnlicher Effekt mit Hilfe von benutzerdefinierten Blöcken mit der Option "ohne Bildschirmaktualisierung laufen lassen" erreicht werden kann.

Stummschaltung

Wird die Strg-Taste gehalten (auf Mac Systemen ist die Cmd-Taste zu verwenden) während auf die grüne Flagge geklickt wird, dann läuft das Projekt ohne Tonausgabe.

Listen

Halten der Umschalttaste während ein Listenelement bearbeitet wird erzeugt einen neuen Eintrag davor. Drücken der Tabulatortaste bewegt den Fokus auf das nächste Element, drücken von Umschalttaste und Tabulatortaste hüpft ein Element zurück.

Block-Argumente

Drücken der Tabulatortaste während gerade ein Argument eines Blocks bearbeitet wird hüpft zum nächsten Argument des Blocks. Mit Umschalttaste+Tabulatortaste springt der Cursor zum vorigen Argument zurück.

Tool Buttons

Deleting a sprite with the "scissors" tool.

Die obere Leiste des Scratch-Editors enthält ein Stempelwerkzeug, eine Schere, Pfeile nach außen, Pfeile nach innen und einen Fragezeichenknopf. Wenn diese Funktionen angklickt werden, kann man damit

  • Figuren, Blöcke, Kommentare, Kostüme und Sounds duplizieren oder löschen,
  • Figuren und Kostüme vergrößen oder verkleinern
  • die Hilfefunktion zu einem Block oder einem anderen Teil der Scratch-Oberfläche aufrufen.

Nachdem ein Werkzeug angewendet wurde ist es wieder abgewählt, das heißt es erneut angeklickt werden um es zum Beispiel erneut einzusetzen. Stattdessen kann man das Tool aber auch mit gedrückter Umschalttaste auswählen, womit es dann aktiviert bleibt bis es wieder abgewählt wird.

Mehrfachauswahl bei Kostümen und Figuren

Wenn eine neue Figur importiert wird, können mit Hilfe der Umschalttaste mehrere Figuren auf einmal ausgewählt werden. Dasselbe Prinzip gilt beim Importieren von Kostümen.

Malprogramm

Das Malprogramm hat ebenfalls mehrere Funktionen die mit der Umschalttase aktiviert werden können.

Duplizieren-Werkzeug

Wenn das Duplizieren-Werkzeug (Stempel) im Vektor-Editor ausgewählt ist, kann durch Halten der Umschalttaste dasselbe Objekt mehrfach kopiert werden ohne es jedesmal neu auswählen zu müssen.

Spline-Bearbeitung

Der Scratch 2.0 vector editor verwendet sogenannte Splines (Kurven mit Stützpunkten). Wenn die Spline-Punkte mit dem Reshape Tool bearbeitet werden kann man einen Punkt mittels Umschaltaste und Mausklick von seinem Objekt lösen. Dazu bewirkt Umschalttaste und Klicken auf einen Punkt zwischen zwei Splines dass ein neuer Spline mit einer Biegung ziwschen den beiden benchbarten Splines entsteht.

Perfekte Formen

Wenn ein Rechteck gezeichnet wird, kann es durch Halten der Umschalttase in ein Quadrat umgewandelt werden. Dassalbe gilt für das Ellipsen-Werkzeug welches durch Drücken der Umschaltaste perfekte Kreise generiert. Wenn das Linientool ausgewählt ist, bewirkt das Drücken der Umschalttaste, dass die Linien perfekt vertikal oder horizontal ausgerichtet werden.

Klang-Editor

Der Klang-Editor hat zwei Funktionen welche mittels der Umschalttaste aktiviert werden:

Beschneiden von Sounds

Sounds können beschnitten werden in dem der Bereich den man behalten will ausgewählt wird. Der nichtmarkierte Bereich kann dann mittels der Tastenkombination Umschalttase+Entfernen oder Umschalttaste+Rücktaste entfernt werden

Anwenden von Effekten

Durch Halten der Umschalttaste und Anklicken des Effekt-Menus können die Funktionen zum lauter oder leisermachen eines Sounds mit einer feineren Schrittweite verwendet werden.

Horizontales Scrolling im Skript-Editor

Im Skript-Bereich kann durch Halten der Umschalttaste das Mausrad zum horizontalen Scrollen verwendet werden.

Rendering

Durch Drücken von Strg+m (Cmd+m unter Mac OS X) schaltet Scratch zwischen dem Grafik-Renderer Pixel Bender und Stage3D um.