Aus Das deutschsprachige Scratch-Wiki

Dieser Artikel ist veraltet, bleibt aber aus geschichtlichen Gründen bestehen.
Der aktuelle Artikel ist Scratch-Oberfläche.



Dieser Artikel behandelt das Interface von Scratch 1.4.

Allgemeiner Aufbau

Interface.JPG

Rechter Bereich

In der Mitte seht Ihr eine Katze in einem weißen Bereich. In diesem Bereich spielt sich das ganze Projekt ab. Ganz oben seht Ihr einmal eine Kontrolleiste, mit der Ihr Objekte vergrößern, verkleinern, kopieren und löschen könnt, und ganz rechts 3 Button, mit denen Ihr einstellen könnt wie groß der Hauptbereich angezeigt werden soll. Ganz unten seht Ihr wieder die Katze. In diesem Bereich befinden sich alle Objekte, die Euer Projekt beinhaltet. Ihr könnt Objekte mit Hilfe der 3 Buttons über den Objekten hinzufügen. Mit dem linken Button könnt Ihr ein neues Objekt zeichnen. Mit dem Button in der Mitte könnt Ihr ein Objekt aus der Scratch-Datenbank laden. Der rechte Button lädt ein zufälliges Objekt.

Linker Bereich

Hier seht Ihr die Blöcke, mit denen Ihr Euere Projekte "bauen könnt". Alle Blöcke sind im acht Katigorien aufgeteilt:

  • Bewegungsblöcke
  • Aussehensblöcke
  • Klangblöcke
  • Malstiftblöcke
  • Kontrollblöcke
  • Fühlblöcke
  • Operatorenblöcke
  • Variabelblöcke

Ihr müsst die Blöcke einfach in den Bereich in der Mitte ziehen, indem Ihr dann euer Programm "bauen" könnt.

Bereich in der Mitte

In dem Bereich in der Mitte findet Ihr oben Objekt eigenschaften, sowie ein Feld, indem der Objektname steht. Darunter könnt Ihr zwischen drei Feldern auswählen:

  1. Hier könnt Ihr verschiedene Skripte mit Hilfe der Blöcke schreiben
  2. Hier seht Ihr die verschiedenen Kostüme des ausgewählten Objektes. Ihr könnt einfach Objekte hinzufügen, bearbeiten und löschen
  3. Hier befinden sich die Klänge der Objekte


Kontrolleiste

Unten seht Ihr ein Bild der Kontrollleiste von Scratch:

Kontrollleiste.jpeg

Sprachauswahl

Hier kannst du die Sprache von Scratch einstellen. Ein Klick auf "Mehr" zeigt noch weitere Sprachen.

Projekt speichern

Speichere dein Projekt.

Projekt veröffentlichen

Mit diesem Button kannst du dein Projekt auf scratch.mit.edu veröffenlichen. Hilfe dazu findest du hier.

Menüleiste (Datei)

Erstelle mit "NEU" ein neues Projekt.
Mit "ÖFFNEN" kannst du ein bereits gespeichertes Projekt öffnen.
Mit "SPEICHERN" kannst du dein Projekt speichern.
Mit "SPEICHERN ALS" kannst du dein Projekt in einem anderen Verzeichnis oder unter einem anderem Namen speichern.
Mit "PROJEKT IMPORTIEREN" kannst du in ein Projekt öffnen und dessen Objekte und Skripte zu dem aktuellen Projekt hinzufügen.
Mit "OBJEKT EXPORTIEREN" kannst du ein Objekt außerhalb deines Projektes speichern. Ein Objekt erkennst du im Windows Explorer an der Dateiendung .sprite
Klicke auf "PROJEKTANMERKUNGEN", um die Anmerkungen zu einem Projekt zu lesen oder zu ändern.
Wenn du auf "BEENDEN" klickst, wird Scratch geschlossen.
Wenn du mit Shift gedrückt auf Datei klickst öffnen sich eine weitere Optionen "PROJEKT ZUSAMMENFASSUNG SCHREIBEN" Wenn man darauf klickt wird eine Text-Datei erstellt im der das Projekt in einem Text zusammen gefasst wird (Quelle meew0).

Menüleiste (Bearbeiten)

"LÖSCHEN RÜCKGÄNGIG MACHEN" stellt das zuletzt gelöschte Objekt oder Skript wieder her.
"AUSFÜHRUNG IN EINZELSCHRITTEN" (siehe Einzelschritte)
"EINZELSCHRITTE EINSTELLEN" (siehe Einzelschritte)
Klicke "KLÄNGE KOMPRIMIEREN" oder "BILDER KOMPRIMIEREN" an, um die Größe deines Projekts zu reduzieren.
Wenn du "MOTORBAUSTEINE ANZEIGEN" anklickst, werden dir auch die Motorblöcke angezeigt.

Menüleiste (Veröffentlichen)

Wenn du dein Projekt im Internet zeigen möchtest, klicke "DIESES PROJEKT IM INTERNET VERÖFFENTLICHEN" an.
Mit einem Klick auf "DIE SCRATCH WEBSEITE BESUCHEN", öffnet sich dein Browser und zeigt die Scratch- Homepage an.

Menüleiste (Hilfe)

"HILFE- SEITE" zeigt die Offline- Scratch Hilfe an.
"HILFE- SEITEN" zeigt die Hilfe zu allen Blöcken an.
"ÜBER SCRATCH" öffnet ein Fenster mit Informationen u.a. zu deiner Scratch- Version.

Stempel

Kopiere ein Objekt oder ein Skript durch Anklicken.

Schere

Lösche ein Objekt oder ein Skript durch Anklicken.

Vergrößern/ Verkleinern

Vergrößere oder verkleinere ein Objekt durch Anklicken.

Bühnengröße

Stelle deine Bühne klein, groß oder öffne den Präsentationsmodus.

Grüne Flagge

Starte deine Skripte, die einen Wenn Grüne Flagge angeklickt (Block) am Anfang haben. Stattdessen kannst Du auch die Enter-Taste benutzen.

"Stoppschild"

Stoppe alle Skripte.



Code zum Einbinden ins Forum:
[wiki=de:Scratch-Oberfläche/Scratch1.4]Scratch-Oberfläche/Scratch1.4[/wiki]